What are the requirements to run SimpleSafe?

SimpleSafe is a self-hosted application and will require web server access and a basic understanding of FTP (or Shell) and database creation. Regular database backups and use of a secure HTTP (HTTPS) connection is highly recommended.

Minimum Requirements: PHP 5.2.4+, MySQL 5.0+ and a modern web browser - Google Chrome 15+, Safari 5+, Mozilla Firefox 8+, or (if you must) Internet Explorer 9+. One click copy to clipboard requires Adobe Flash to be installed, but this feature is optional.

Is it a hosted app?

No. SimpleSafe is provided as a downloadable web application (PHP & MySQL) which you’ll need to install on your own server. The installation process is easy and should take only a few minutes – you’ll just need basic knowledge of database creation and a place to keep your files.

Is it just a one time fee?

Yes, SimpleSafe is licensed just like desktop software. All minor updates will be free for existing users and major updates (eg v1 to v2) will be made available to purchase at a discounted rate.

Can I import existing data?

Certainly. You can import data into SimpleSafe via a comma delimited text file (.txt or .csv) and even use your imported data to create the fields you’ll use for the app.

Why do I need a user account?

Your user account is used to store your license details, access application updates and contact support.

What security measures I should take?

We highly recommend utilising a HTTPS connection and keeping regular database backups to make sure your data is kept safe and secure.

Use common sense – utlize secure passwords, never share them with anyone and only provide access to those necessary. Make sure the computers and servers you use are free of spyware, malware, and virus infections and ensure that file permissions are locked down.

Smarter, simpler credential management.

Get SimpleSafe Now

$90 one time fee. Not sure? Try the demo.